学习啦——考试网 > 计算机类 > 计算机等级 > 资讯 > 《2015年网络工程师学习笔记:交换机配置》正文

2015年网络工程师学习笔记:交换机配置

时间:2015-09-17 15:36:58本文内容及图片来源于读者投稿,如有侵权请联系xuexila888@qq.com 家辉 我要投稿

  计算机四级网络工程师主要考察考核网络系统规划与设计的基础知识及中小型网络的系统组建、设备配置调试、网络系统现场维护与管理的基本技能。以下是学习啦小编为你整理的2015年计算机四级考试网络工程师学习笔记:交换机及其配置,供大家参考和学习。

  交换机及其配置

  局域网交换机基本功能:

  (1) 建立和维护一个表示 MAC 地址与交换机端口对应关系的交换表

  (2) 发送结点和接收结点之间建立一条虚连接

  (3) 完成数据帧的转发或过滤

  显示交换机命令: 大中型交换机:show cam dunamic 小型交换机:show mac-address-

  table

  交换机的交换结构

  (1) 软件执行交换结构(把数据帧由串行代码转换成并行代码)特点:交换速度慢,交换机

  堆叠困难,交换机端口较多导致性能下降

  (2) 矩阵交换结构(完全由硬件完成,由输入,输出,交换矩阵和控制处理) 特点:交换速

  度快,延时小,结构紧凑,矩阵交换实现相对简单,不易扩 展,不利于管理

  (3) 总线交换结构(时分多路复用技术)特点:性能好,便于堆叠扩展,易实现帧广播和监

  控管理,易实现多个输入对一个输出的帧传送的特点。 应用广泛

  (4) 共享存储器交换结构(无背板)特点:结构简单,易实现适合小交换机采用

  交换机有静态交换和动态交换两种方式,动态交换模式有存储转发和直通,直通交换模式

  又有快速转发交换和碎片丢弃交换

  总结说有 3 模式:

  快速转发(通常也称直通交换模式,不提供检错纠错,适合小型交换机采用)

  碎片丢失(又称无分段模式,提前过滤冲突碎片,提高宽带利用率)

  存储转发(延时大,速度慢,可靠性高,可检错纠错,最为广泛应用)

  堆叠交换机:2-10gbps 6-8 个堆叠数量 有达 16 个的 箱体模块化交换机:2-20 个

  VLAN 技术特性: 工作在数据链路层

  每个 VLAN 都是一个独立的逻辑网段,一个独立的广播域

  VLAN 之间不能直接通信,必须通过第三层路由功能完成

  VLAN 标识,vlan id 用 12 位 bit 表示,支持 4096 个 vlan ;1-1005 是标准范围,其

  中 1-1000 是用于以太网

  交换机之间实现 trunk 功能,必须遵守相同的 vlan 协议,如思科 isl

  划分 vlan

  (1) 基于端口划分(静态划分,最通用)

  (2) 基于 mac 地址(动态的划分)

  (3) 第三层协议类型或地址

  交换机配置

  duplex auto/full/half 配置端口通信方式

  speed 10/100 speed auto 端口传输速率

  VTP 实现 VLAN 的单一管理

  Switch(config)#vtp domain todd 设置域名

  Switch(config)#vtp password aaa

  Switch(config)#vtp mode client /server/transparent

  虚拟局域网 VLAN

  查看VLAN 命令 Switch#show vlan

  创建 VLAN Switch#config t Switch(config)#vlan 2

  Switch(config-vlan)#ex

  Switch(config)#interface range fastEthernet 0/11 - 24

  Switch(config-if-range)#switchport access vlan 2

  建立,修改: vlan 1000 name vlan1000

  删除:no vlan 1000

  vlan interface f0/1

  switchport access vlan 1000

  Switch(config)#interface vlan 1

  Switch(config-if)#ip address 192.168.0.100 255.255.255.0

  Switch(config-if)#no sh

  Switch(config-if)#exit

  Switch(config)#ip default-gateway 192.168.0.1

  Switch(config)#enable password aaa

  Switch(config)#line vty 0 4

  Switch(config)#line vty 0 15

  Switch(config-line)#password aaa

  Switch(config-line)#login

  VLAN Trunk

  Switch(config-if)#switchport mode trunk

  Router(config)#interface gigabitEthernet 6/0

  Router(config-if)#no sh

  Router(config)#interface gigabitEthernet 6/0.1

  Router(config-subif)#encapsulation dot1Q 1

  Router(config-subif)#ip address 192.168.0.1 255.255.255.0

  带路由模块的交换机实现 VLAN 间路由

  两台交换机配置 trunk:

  Conf t

  Interface f0/0

  Switchport mode trunk

  Switchport trunk encapsulation dot1q/isl

  Switchport trunk allowed vlan 1,4

  Switchport trunk allowed vlan 1-4

  Switchport trunk allowed except vlan 1-2

  生成树(STP)

  Spanning-tree vlan 2

  No spanning-tree vlan 2 打开与关闭树

  Spanning-tree vlan 2 root primary 设置主 root根网桥

  Spanning-tree vlan 3 root secondary 设置备份 root 备份网桥

  Spanning-tree vlan 3 priority 8192 设置优先级(0,4096,8192.。。。 到 61440)

  配置可选功能:

  Spanning-tree backbonefast (不是连接 本交换机的链路失效时) 30 秒

  Spanning-tree uplinkfast (连接本交换机链路失效 1-5 分钟

  Spanning-tree uplinkfast max-update-rate (0-32000)

  Spanning-tree portfast default

  Spanning-tree portfast bpdufilter default

Copyright @ 2006 - 2018 学习啦 All Rights Reserved

学习啦 版权所有 粤ICP备15032933号-1

学习啦 学习啦

回到顶部